Июл
24
5

Отказ от PHP 4 и MySQL 4 для WordPress 3.2

php для wordpressНа официальном блоге системы wordpress недавно появилось весьма интересное объявление – следующие версии станут последними для PHP 4 и MySQL 4, которые в дальнейшем не будут поддерживаться. Многие уже могли почитать об этом в твиттере или технических порталах, но я просто не мог упустить такое событие и не опубликовать в новостях блога.

По словам разработчиков для wordpress всегда использовался подход, чтобы система могла работать на разных настройках сервера. Это делалось исходя из соображений гибкости выбора хостинга под свой блог или сайт. Благодаря этой стратегии можно было установить wordpress практически везде, где была поддержка PHP и MySQL. Однако процесс технологического развития хостинга не стоит на месте, поэтому было бы логично следовать этому процессу и вносить коррективы в работу и требования wordpress. Собственно, такое время настало – в результате чего поддержка PHP 4 и MySQL 4 со временем будет прекращена.

Таким образом следующая версия wordpress 3.1, которая выйдет в конце 2010 года станет последней, где будет применятся поддержка PHP 4. Для WordPress 3.2, запланированного на первую половину 2011 минимальные требования хостинга по PHP будут повышены до версии 5.2. Данная версия используется большинством пользователей системы wordpress, а также предполагает наличие значительных улучшений по сравнению с более ранними релизами. Кстати, следует заметить, что PHP 5.2 станет также минимальным требованием для следующих версий систем Drupal и Joomla, которые выйдут в этом году.

Так что, в принципе, здесь нет ничего страшного, помнится когда я еще очень тесно работал с typo3 cms, там переезд осуществили весьма безболезненно и еще раньше. В поддержку этого решения также выступают цифры и информация о системе. Например, всего 11% пользователей установленных систем WordPress работают на  PHP ниже версии 5.2. Более того, часть из них работают с хостингом, который эту версию поддерживает – то есть, по сути, ми нужно будет просто изменить настройки хостинга в соответствующей админ панели.

Разработчики по праву считают, что процент использования старых версий PHP со временем в течении года будет снижаться и дальше ибо хостеры просто обязаны будут это сделать для поддержки не только WordPress, но и других CMS (как например, Drupal или Joomla). Очень хочется надеяться, что такая тенденция будет применима не только к мировым хостинг провайдерам, но и отечественным.

Чуть менее грандиозной новостью можно считать отказ от поддержки MySQL 4 после версии WordPress 3.1. По статистике эту версию MySQL используют менее 6% пользователей. Минимальным требованием для WordPress 3.2 станет MySQL 5.0.15.

Те пользователи, чьи хостинговые настройки не будут удовлетворять дальнейшим требованием системы просто не смогут обновиться до версии WordPress 3.2. Для определения версий нужного ПО на хостинге был создан специальный плагин — Health Check. Пока что он показывает подходит ли ваш хостинг для WordPress 3.2, но в дальнейшем планируется значительно расширить его функциональность, чтобы он показывал также всю информацию о вашей установленной системе WordPress.

В качестве итогов можно сказать, что, в принципе, ничего страшного не случилось. Вообще когда я первых раз увидел эту новость, то меня одолевали двоякие ощущения мол как они могут вот так взять и отказаться от поддержки PHP 4 и MySQL 4. Но, почитав статью подробнее и вспомнив переход на PHP 5 для typo3 (а также инфу о Drupal и Joomla), понимаю, что все будет нормально:) Есть риск получить немного проблем с дешевыми и неграмотными хостингами, но с таких в любом случае лучше съезжать заранее. Большинство, надеюсь, учтет требования WordPress и других систем управления сайтами. В любо случае до 2011 время еще есть.

Что думаете по поводу отмены поддержки PHP 4 и MySQL 4?

P.S. Постовой. Читаем интересный и полезный блог о заработке в сети с нуля и без опыта.

рейтинг Оцените статью:
Ужасная статьяНичего интересногоТак себеНормальноХорошоКлассный постВ закладки!
(голосов - 2, средний балл: 4,00 из 7)
Загрузка...

категория Категории: Новости;
теги Теги: , , , .

комментариев 5 к статье “Отказ от PHP 4 и MySQL 4 для WordPress 3.2”

  • BOLVERIN   24.07.2010

    хорошее решение для пользователей WP. надеюсь и качество работы с БД увеличат :)

  • eavasi   25.07.2010

    Полностью поддерживаю отказ от php4. Все должно двигатся вперед и развиваться.
    Если дополнительно будут проведены по повышеню производительности и быстродействию скрипта WordPress — будет совсем замечательно.
    Когда вышла версия 3.0 и я перешел на нее, я всерьез задумался об отказе от WordPress в пользу Maxsite CMS, но некоторые технические моменты не дали мне перейти на Макссайт и я ограничился только покупкой скрипта Макскеш для кеширования WordPress.

  • toribloger   25.07.2010

    насколько помню, оба мои хостера довольно продвинутые и мне особенно ничего менять не придется )) поэтому я вполне за изменения… главное, чтоб себя оправдывало и давало реальные измения к лучшему!

  • rxs   25.07.2010

    Поскольку отказ будет с версии 3.2 (т.е в 2011 году), то у хостеров достаточно времени, чтобы обновить парк серверов и набор ПО.
    Если же кто-то так не сделает, то не будет жаль. Такой хостер не слишком ценен, как и блоги, находящиеся у такого хостера.

  • Алекс   05.08.2010

    Да вы что! сейчас у всех нормальных хостеров, который обеспечивают бесперебойную работу, выдерживают траффик и т.п. всё уже по новому образцу. Так как на них не только вордпресс ставят. Ну а хостеры для вордпресс за новостями следят :)

Оставить комментарий


Блог Wordpress Inside поможет вам научиться работать в вордпресс, закрепить и расширить имеющиеся знания. Плагины и шаблоны, разные хаки и функции wp, оптимизация и безопасность системы – все это и намного больше вы сможете найти на страницах нашего проекта!

Если хотите быстро и оперативно получать последние новости и статьи, то рекомендуем подписаться на обновления блога:

Последние посты
Лучшее в категории
Облако тегов
Скажи свое мнение!

В чем основные плюсы Wordpress?

Посмотреть результаты

Загрузка ... Загрузка ...
Друзья проекта
Последние новости